Skip to main content
← All vulnerabilities
CVE-2023-38495GHSA-PJ4X-2XR5-W87MBIT-CROSSPLANE-2023-38495GO-2023-1980

Crossplane vulnerable to possible image tampering from missing image validation for Packages

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.11.5, 1.12.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, Crossplane's image backend does not validate the byte contents of Crossplane packages. As such, Crossplane does not detect if an attacker has tampered with a Package. The problem has been fixed in 1.11.5, 1.12.3 and 1.13.0. As a workaround, only use images from trusted sources and keep Package editing/creating privileges to administrators only.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • crossplane crossplane

    fixed in 1.11.5; From 1.12.0 · fixed in 1.12.3

  • github.com/crossplane/crossplaneGo

    fixed in 1.11.5

  • github.com/crossplane/crossplaneGo

    From 1.12.0 · fixed in 1.12.3

  • github.com/crossplane/crossplaneGo

    fixed in 1.11.5; From 1.12.0 · fixed in 1.12.3

References 2

GitHub · crossplane/crossplane