Skip to main content
← All vulnerabilities
CVE-2023-38219GHSA-3J7W-JP46-9752

Validate Your Inputs | Cross-site Scripting (Stored XSS) (CWE-79) - Customer to Admin stored XSS with Gift wrapping

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7-beta2, 2.4.6-p3, 2.4.5-p5, 2.4.4-p6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.7-beta1 (and earlier), 2.4.6-p2 (and earlier), 2.4.5-p4 (and earlier) and 2.4.4-p5 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Payload is stored in an admin area, resulting in high confidentiality and integrity impact.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.7-beta1

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-beta2

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p3

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p5

  • magento/community-editionPackagist

    From 2.4.4-p1 · fixed in 2.4.4-p6

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com