Skip to main content
← All vulnerabilities
CVE-2023-36806GHSA-4GPR-P634-922X

Contao cross site scripting vulnerability via input unit widget

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.9.42, 4.13.28, 5.1.10
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • contao contao

    From 4.0.0 · fixed in 4.9.42; From 4.10.0 · fixed in 4.13.28; From 5.0.0 · fixed in 5.1.10

  • contao/core-bundlePackagist

    From 4.0.0 · fixed in 4.9.42

  • contao/core-bundlePackagist

    From 4.10.0 · fixed in 4.13.28

  • contao/core-bundlePackagist

    From 5.0.0 · fixed in 5.1.10

References 5

GitHub · contao/contao

herolab.usd.de