Skip to main content
← All vulnerabilities
CVE-2023-35941

Envoy vulnerable to OAuth2 credentials exploit with permanent validity

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.26.4, 1.25.9, 1.24.10, 1.23.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12, a malicious client is able to construct credentials with permanent validity in some specific scenarios. This is caused by the some rare scenarios in which HMAC payload can be always valid in OAuth2 filter's check. Versions 1.27.0, 1.26.4, 1.25.9, 1.24.10, and 1.23.12 have a fix for this issue. As a workaround, avoid wildcards/prefix domain wildcards in the host's domain configuration.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • envoyproxy envoy

    From 1.26.0 · fixed in 1.26.4; From 1.25.0 · fixed in 1.25.9; From 1.24.0 · fixed in 1.24.10; fixed in 1.23.12

References 1

GitHub · envoyproxy/envoy