CVE-2023-3526
PHOENIX CONTACT: Cross-site Scripting vulnerability in TC ROUTER, TC CLOUD CLIENT and CLOUD CLIENT devices
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.06.10, 2.07.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
In PHOENIX CONTACTs TC ROUTER and TC CLOUD CLIENT in versions prior to 2.07.2 as well as CLOUD CLIENT 1101T-TX/TX prior to 2.06.10 an unauthenticated remote attacker could use a reflective XSS within the license viewer page of the devices in order to execute code in the context of the user's browser.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- PHOENIX CONTACT CLOUD CLIENT 1101T-TX/TX
fixed in 2.06.10
- PHOENIX CONTACT TC CLOUD CLIENT 1002-4G
fixed in 2.07.2
- PHOENIX CONTACT TC CLOUD CLIENT 1002-4G ATT
fixed in 2.07.2
- PHOENIX CONTACT TC CLOUD CLIENT 1002-4G VZW
fixed in 2.07.2
- PHOENIX CONTACT TC ROUTER 3002T-4G
fixed in 2.07.2
- PHOENIX CONTACT TC ROUTER 3002T-4G ATT
fixed in 2.07.2
- PHOENIX CONTACT TC ROUTER 3002T-4G VZW
fixed in 2.07.2