CVE-2023-35133GHSA-XXP4-MF4H-6CWMBIT-MOODLE-2023-35133
Moodle: ssrf risk due to insufficient check on the curl blocked hosts
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.2.1, 4.1.4, 4.0.9, 3.11.15, 3.9.22
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
An issue in the logic used to check 0.0.0.0 against the cURL blocked hosts lists resulted in an SSRF risk. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- moodle
From 4.2.0 · fixed in 4.2.1; From 4.1.0 · fixed in 4.1.4; From 4.0.0 · fixed in 4.0.9; From 3.11.0 · fixed in 3.11.15; fixed in 3.9.22
- moodle/moodlePackagist
From 4.2.0 · fixed in 4.2.1
- moodle/moodlePackagist
From 4.1.0 · fixed in 4.1.4
- moodle/moodlePackagist
From 4.0.0 · fixed in 4.0.9
- moodle/moodlePackagist
From 3.10.0 · fixed in 3.11.15
- moodle/moodlePackagist
fixed in 3.9.22