Skip to main content
← All vulnerabilities
CVE-2023-34238GHSA-C6F8-8R25-C4GC

Local File Inclusion vulnerability in Gatsby

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.9.1, 4.25.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Gatsby is a free and open source framework based on React. The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the `file-code-frame` and `original-stack-frame` paths, exposed when running the Gatsby develop server (`gatsby develop`). Any file in scope of the development server could potentially be exposed. It should be noted that by default `gatsby develop` is only accessible via the localhost `127.0.0.1`, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as `--host 0.0.0.0`, `-H 0.0.0.0`, or the `GATSBY_HOST=0.0.0.0` environment variable. A patch has been introduced in `gatsby@5.9.1` and `gatsby@4.25.7` which mitigates the issue. Users are advised to upgrade. Users unable to upgrade should avoid exposing their development server to the internet.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • gatsbyjs gatsby

    From 5.0.0 · fixed in 5.9.1; fixed in 4.25.7

  • gatsbynpm

    fixed in 4.25.7

  • gatsbynpm

    From 5.0.0 · fixed in 5.9.1

References 3

GitHub · gatsbyjs/gatsby