Skip to main content
← All vulnerabilities
CVE-2023-34189GHSA-86PW-4RQP-6X7V

Apache InLong: General user can delete and update process

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Exposure of Resource to Wrong Sphere Vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.7.0. The attacker could use general users to delete and update the process, which only the admin can operate occurrences.  Users are advised to upgrade to Apache InLong's 1.8.0 or cherry-pick https://github.com/apache/inlong/pull/8109  to solve it.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache InLong

    From 1.4.0 · through 1.7.0

  • org.apache.inlong:inlong-managerMaven

    From 1.4.0 · fixed in 1.8.0

References 2

lists.apache.org

openwall.com