Skip to main content
← All vulnerabilities
CVE-2023-33966GHSA-VC52-GWM3-8V2F

Deno missing "--allow-net" permission check for built-in Node modules

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.34.1, 0.115.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Deno is a runtime for JavaScript and TypeScript. In deno 1.34.0 and deno_runtime 0.114.0, outbound HTTP requests made using the built-in `node:http` or `node:https` modules are incorrectly not checked against the network permission allow list (`--allow-net`). Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0 are unaffected. Deno Deploy users are unaffected. This problem has been patched in Deno v1.34.1 and deno_runtime 0.114.1 and all users are recommended to update to this version. No workaround is available for this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • denoland deno

    deno = 1.34.0, deno_runtime = 0.114.0

  • denocrates.io

    From 1.34.0 · fixed in 1.34.1

  • deno_runtimecrates.io

    From 0.114.0 · fixed in 0.115.0

References 2

GitHub · denoland/deno