Skip to main content
← All vulnerabilities
CVE-2023-32711

Persistent Cross-Site Scripting (XSS) through a URL Validation Bypass within a Dashboard View

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.1.14, 8.2.11, 9.0.5
None on Exploit-DB, Metasploit or GitHub

Summary

In Splunk Enterprise versions below 9.0.5, 8.2.11, and 8.1.14, a Splunk dashboard view lets a low-privileged user exploit a vulnerability in the Bootstrap web framework (CVE-2019-8331) and build a stored cross-site scripting (XSS) payload.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Splunk Splunk Enterprise

    From 8.1 · fixed in 8.1.14; From 8.2 · fixed in 8.2.11; From 9.0 · fixed in 9.0.5

References 2

advisory.splunk.com

research.splunk.com