Skip to main content
← All vulnerabilities
CVE-2023-32200GHSA-J927-W6G7-7C7W

Apache Jena: Exposure of execution in script engine expressions.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.9.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

There is insufficient restrictions of called script functions in Apache Jena versions 4.8.0 and earlier. It allows a remote user to execute javascript via a SPARQL query. This issue affects Apache Jena: from 3.7.0 through 4.8.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Jena

    From 3.7.0 · through 4.8.0

  • org.apache.jena:jenaMaven

    From 3.7.0 · fixed in 4.9.0

References 2

cve.org

lists.apache.org